Nucleus error log shows Underlying connection closed: Could not establish trust relationship; Corrupt Nucleus certificate
Potential Symptoms
- Receive the following error in the Nucleus Error.log:
- The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel, but the error is not showing in the Fusion Event log.
Environment
- Product Family: Software
- Products:
- Components: Nucleus Server
- Control System: Venus 1500 v4
Cause
- The Nucleus Certificate has become corrupted.
- This error does not appear in the Fusion Event logs. If you see this error in the Fusion Event logs, please see the following article:
- Follow article Daktronics Fusion Certificate Error, DD2470492
Resolution
-
Go to Windows Start Menu.
-
Windows XP - Click Run, type MMC and hit [Enter]
-
Windows Vista or 7 - In the Search Programs and Files, type MMC, select MMC from filtered Start Menu
-
Windows 8 - Hover to bottom right of desktop, click Magnifying Glass, type MMC and hit [Enter]
-
-
From the MMC Console, click File -> Add/Remove Snap-in.
-
Under Available snap-ins menu, select Certificates and click Add > to push to Selected snap-ins menu.
-
From the Pop-up window, select Computer Account and click Next.
-
Leave on or select Local Computer and click Finish.
-
Click Ok.
-
In the Name panel, double-click Certificates (Local Computer).
-
In the Logical Store Name panel, double-click Trusted Root Certification Authorities.
-
In the Object Type panel, double-click Certificates.
-
Under the Issued To column, browse and select the Daktronics Nucleus.
- Below is a screen shot view of what you should see
- If the Daktronics Nucleus is not listed, proceed to Step 2
-
Once Daktronics Nucleus is Selected, click the Red X, hit [Delete] or go to Actions -> Delete.
-
Click Yes to the prompt.
-
Close out of the MMC Console, click No to save the Console.
-
Follow How do I run a repair on installed software such as Venus 1500, Vanguard or Show Control?, DD2387771 (Preferred method)
or
-
Follow How do I update or download Venus 1500 v4 software?, DD1993540
- Do not uninstall Venus 1500 v4 if currently installed; instead, perform a software repair.
KB ID: DD2605323
DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.
DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.
The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.