Can't communicate with display, MOXA adapter driver is not installed.

Potential Symptoms

  • "Connect Failed" alert in Venus 1500 V4.
  • Cannot communicate to the display using a MOXA USB to Serial adapter.
  • When viewing in Device Manager, UPort 11XX may have a yellow triangle symbol with exclamation point or question mark next to it.
  • Device Manager  - Moxa Properties is showing Code 28

Environment

  • Product Family: Message Displays
  • Product:
  • Component: MOXA USB to Serial adapter
  • Control System: Venus 1500

Cause

  • Driver not installed properly.

Resolution

  • untitled.pngMoxa USB to Serial adapter image.

Step 1: Get the driver online or off the CD that comes with the adapter.

  1. First step is to try plugging the USB adapter into another USB port on the computer (if driver was installed while adapter was plugged into computer, it only installs it for that specific port...if cable was plugged into incorrect port it will show up under USB-Serial Adapter in other Devices with a yellow exclamation point or question mark). If this does not resolve issue proceed to #2.
  2.  Driver can be found at the following site or on the CD (driver disk) that came with the MOXA adapter: https://www.moxa.com/en/  
Step 2: Install the driver.
  1. Remove any previous driver software from computer.
  2. Reboot computer.
  3. Locate the correct driver for USB adaptor depending on PC operating system.
  4. Have USB to serial adapter unplugged from the computer at this time.
  5. Look for the driver applicable to the operating system in use in the U1100 folder under Software and follow the steps to install the driver. The installer will tell you when it is ok to plug in the adapter.
  6. Make sure MOXA USB to serial adapter is recognized in Device manager.
Step 3: Verify com port driver is using and setting up the Venus 1500 software.
  • Configure correct com port number in Venus 1500 software with com port in Device manager when plugged in.

KB ID: DD2716267


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.