A network-related or instance-specific error..., SQL installed but cannot manually start

Potential Symptoms

  • When installing Venus 1500 v4 (full or lite), receive the following error:
    A network-related or instance-specific error ...
  • If Venus is already installed: Unable to manually start the SQL service, getting:
    •  "error 3417. " windows could not start the SQL Server (nucleus) on local computer.",
    • and other error in Event Viewer.    "FCB::Open failed: Could not open file C:\Program Files (x86)\Microsoft SQL Server\MSSQL12.NUCLEUS\MSSQL\DATA\mastlog.ldf for file number 2. OS error: 5(Access is denied.)."

Environment

  • Venus 1500 v4
  • Windows XP, 7
  • Microsoft SQL Server 2005, 2014

Cause

  • Improper sharing of the Microsoft SQL Server folder.
    • To verify issue, open Event Viewer and examine the Application logs.  There should be several errors that all reference an Access Denied type error (e.g. FCB:: Open failed:  could not open file c:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\master.mdf for file number 1. OS error 5 (Access is denied)).

Resolution

  1. Will need to be logged on as Administrator.
  2. Locate the Microsoft SQL Server folder (C:\Program Files\Microsoft SQL Server): could probably go one folder deeper (C:\Program Files\Microsoft SQL Server\MSSQL.1).
  3. Right-click and select Properties.
  4. Select the Security tab.
  5. Give full control privileges to appropriate user (user account under which the software is normally ran);
    1. It may be easiest to add an Everyone Group/user names and give full privileges to everyone.
    2. However this will mean that anyone who logs on to the computer will have full privileges to this folder.
  6. Start the SQL Server (Nucleus) instance manually from Services.
  7. Continue with the installation of the software.

KB ID: DD2398828


DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.