Venus 1500: When updating v4 software receive an error 'The file Nucleus Log.mdf is compressed but does not reside in a read-only database or filegroup.'

Potential Symptoms

  • When updating Venus 1500 v4 software receive an error 'The file Nucleus Log.mdf is compressed but does not reside in a read-only database or filegroup.'

    Error:
    The file "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\Nucleus Log.mdf" is compressed but does not reside in a read-only database or filegroup. The file must be decompressed.
    The file "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\Nucleus Log_log.LDF" is compressed but does not reside in a read-only database or filegroup. The file must be decompressed.
    Database 'Nucleus log' or 'Nucleus Database' cannot be opened due to inaccessible files or insufficient memory or disk space. See the SQL Server Errorlog for details.
    File activation failure. The physical file name "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data\Nucleus Log_Log.LDF" may be incorrect


Environment

  • Venus 1500 (4.9)
  • Configuration
  • Windows XP
  • M3

Cause

  • The Nucleus Database.mdf, Nucleus Log.mdf and Nucleus Log_log.LDF file was compressed and will not allow the software update/repair to run.

Resolution

Step 1: Uncompressed the Files/folders.
  1. Go to Windows Services.
    • XP Operating System: Go to Windows Start Menu -> Run -> type services.msc -> Click Ok
    • Windows 7 Operation System: Go to Windows Start Menu -> In Search programs and files and type Services, and select Services from the filtered menu.
  2. Locate the SQL Server (Nucleus), right-click and Stop it.
  3. Go to C:\Program Files or C:\Program Files (x86)
  4. Right-click on Microsoft SQL Server folder and choose Properties.
  5. From the General Tab click Advanced.
  6. Uncheck Compress contents to save disk space, click Ok
  7. Choose Apply changes to this folder, subfolders and files, click Ok.

Step 2: Detaching and Re-Attaching the Database
  1. Go to https://dakfiles.daktronics.com/ .
  2. Go to the following directory: Venus1500 -> Utils -> Nucleus Database Diagnostics
  3. Click and Download the Nucleus Database Diagnostics.zip file.
  4. Click Open, drag and drop folder contents to computer Desktop.
  5. Double-click the Nucleus Database Diagnostics Application file.
  6. After retrieving status, either click Repair or Detach.
      1. If clicking Detach, click Attach.
      2. Close Nucleus Database Diagnostics.

        Step 3: Run a Update/Repair on software.
        NOTE:  If the "Compress contents to save disk space" is not checked, try checking it and click Ok and Apply changes to the folder, subfolders and files. Then follow steps 6-8.

        KB ID: DD2050600


        DISCLAIMER: Use of this content may void the equipment warranty, please read the disclaimer prior to performing any service of the equipment.

        DAKTRONICS DOES NOT PROMISE THAT THE CONTENT PROVIDED HEREIN IS ERROR-FREE OR THAT ANY DEFECTS WILL BE CORRECTED, OR THAT YOUR USE OF THE CONTENT WILL PROVIDE SPECIFIC RESULTS. THE CONTENT IS DELIVERED ON AN "AS-IS" AND "AS-AVAILABLE" BASIS. ALL INFORMATION PROVIDED IN THIS ARTICLE IS SUBJECT TO CHANGE WITHOUT NOTICE. DAKTRONICS DISCLAIMS ALL WARRANTIES, EXPRESS OR IMPLIED, INCLUDING ANY WARRANTIES OF ACCURACY, NON-INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. DAKTRONICS DISCLAIMS ANY AND ALL LIABILITY FOR THE ACTS, OMISSIONS AND CONDUCT OF YOU OR ANY THIRD PARTIES IN CONNECTION WITH OR RELATED TO YOUR USE OF THE CONTENT. ADJUSTMENT, REPAIR, OR SERVICE OF THE EQUIPMENT BY ANYONE OTHER THAN DAKTRONICS OR ITS AUTHORIZED REPAIR AGENTS MAY VOID THE EQUIPMENT WARRANTY. YOU ASSUME TOTAL RESPONSIBILITY FOR YOUR USE OF THE CONTENT AND ANY LINKED CONTENT. YOUR SOLE REMEDY AGAINST DAKTRONICS FOR DISSATISFACTION WITH THE CONTENT IS TO STOP USING THE CONTENT. THIS LIMITATION OF RELIEF IS A PART OF THE BARGAIN BETWEEN THE PARTIES.

        The above disclaimer applies to any property damage, equipment failure, liability, infringement, or personal injury claim arising out of or in any way related to your use or application of the content, whether such claim is for breach of contract, tort, negligence or any other cause of action.