Nucleus service failing to start, Compressed files or Database needs repair.

Potential Symptoms

  • Receiving error Nucleus service failed to start and the Daktronics Nucleus server will not remain started.
  • When trying to launch software, the error "Nucleus service could not be started. Nucleus service failed to load."
  • When attempting to start or restart Daktronics Fusion receive "The Daktronics Fusion service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.
  • Fusionstartedstopped.png
  • Event Viewer has warning "Service cannot be started. The service process could not connect to the service controller.
  • Service cannot be started.png
  • When trying to start the Daktronics Nucleus Server, it would show started, but the moment you launch the software again, it would stop the service and receive the error.

Environment

  • Product Family: Software
  • Product: Venus 1500
  • Component:
  • Control System:

Cause

  • In some instances, files in the Daktronics folder (Both Program Files and Application Data) and Microsoft SQL Server folder are compressed. To confirm if a file or folder is compressed it would have blue text similar to the image below.
  •  In other instances, the Database needs to be repaired.

Resolution

  1. Confirm if files or folders are compressed.
    1. If files are not compressed, skip ahead to Step 3.
  2. Uncompress all folders, files, and subfolders.
  3. Go to Windows Services.
    • Windows XP: Go to Windows Start Menu -> Run -> type services.msc -> Click Ok
    • Windows Vista or 7: Go to Windows Start Menu -> Search programs and files -> and type services and select Services from the filtered menu.
  4.  Locate the SQL Server (Nucleus) and Daktronics Nucleus Server and stop the service.
  5.  Go to C:\Program Files or C:\Program Files (x86).
  6.  Right-click on the Daktronics folder and the Microsoft SQL Server folder and choose Properties .
  7.  From the General tab click Advanced .
  8.  Uncheck Compress contents to save disk space, click Ok.
  9.  Choose Apply changes to this folder, subfolders and files, click Ok.
    • You may need to re-compress and uncompress the folder a couple times for it to fully uncompress.
    • If Fusion, Database, Common Scheduler,  or other Daktronics files or EXEs will not decompress, stop the Daktronics Services and retry.
    • If the Compress contents to save disk space is not checked, try checking it off and click Ok and Apply changes to the folder, subfolders and files. Then follow steps 6-8 and uncompress the files.
  10. Download and Run the Nucleus Database Diagnostics and repair or detach and attach the databases.
  11. Go to http://dakfiles.daktronics.com -> Venus1500 -> Utils -> Nucleus Database Diagnostics.
  12. Save and Open the .zip file and extract to the Desktop.
  13. Run the utility and Attach or Repair databases if needed.
  14. Locate the SQL Server (Nucleus) and Daktronics Nucleus Server and restart both.
  15. Re-launch Venus 1500 v4.

KB ID: DD2197827


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