No serial communication, Incorrect com port selected in Venus software

Potential Symptoms

  • Cannot communicate or unable to connect to the display.
  • Not getting TX/RX LEDs to flash on the signal converter when getting status or communicating to the display.
  • The Com port field or selection in the Display Configuration is blank.

If using Venus v3:

  • Progress window flashes briefly/quickly when trying to "Get Status" to the display.
  • When trying to communicate or get status, display name will turn red in display list (Error -12, unable to open communication port or Error -7 invalid response).
  • "Memory Full" error when trying to get status or send content to the display.

If using Venus v4:

  • May receive an alert: "Connect failed" or "No Response" (alert will appear immediately upon trying to connect).
  • May receive an alert: "Synchronize Time Zone Unsupported Command".

Environment

  • Product: Galaxy, DataTrac
  • Component: Serial Communication systems, USB to Serial Adapter or Computer COM Port
  • Control System: Venus 1500 v3 or v4

Cause

  • COM port listed in the Device Manager is different from the COM port configured in Venus 1500 software.
    • Venus 1500 application is open when adapter installed and cannot recognize the newly assigned com port for the adapter.
    • Replacement USB adapter and sign is configured for port from old adapter COM assignment.
    • The COM port changes when the USB to serial adapter is plugged into a different USB port on the computer. Keeping the adapter plugged into the same USB port will normally prevent a different COM port from being assigned.
    • USB to Serial adapter was moved to different USB port.
    • Example:
    • Venus software set up to use COM1.
    • Device Manager says USB to Serial adapter uses COM2 or is blank.

Resolution

  1. Open Device Manager on the computer.
  2. Open the Ports (COM & LPT).
  3. Check for the port that the computer or USB to Serial Adapter has available. 
    • If multiple COM ports are available may have to try each of them.  With a USB to serial adapter you can watch the port list while plugging the USB/serial adapter into the USB port and it will populate.
  4. Change the Com port in the Venus 1500 software to match what is being used in Device manager or plug the USB cable into the correct port.

Venus 1500 v3 Instructions    

                                        EDIT

  1. Close out of Venus 1500 Display Manager if opened.
  2. Open up Venus 1500 Administrator.
  3. Select the Network Configuration box near the top.
  4. Right click on the name of your network and select edit.
  5. Under Direct Network Attributes, select correct COM ports and edit the Network name to reflect COM ports.
  6. Press OK once all selections are filled out.
  7. Open Venus 1500 Display Manager and verify communication

                                        NEW

  1. Close out of Venus 1500 Display Manager if opened.
  2. Open up Venus 1500 Administrator.
  3. Select the Network Configuration box near the top.
  4. Right click on Direct Network and select New.
  5. In the Network Configuration Window:
    • Network Name: Name it according to the COM port being used (e.g. COM5 used for port COM5).
    • Network Type: "Direct Networks".
    • COM ports: Select the correct COM port from the drop down arrow box.
    • Press OK once all selections are filled out.
  6. Select the Display Configuration Box near the top.
  7. Expand the display configuration (e.g. Galaxy 32x64 RGB 32K).
  8. Double Click on the display name (e.g. Display 1).
  9. Select the Network that was just created (e.g. COM5) from the drop down menu next to Network.
  10. Open Venus 1500 Display Manager and verify communication.

Venus 1500 v4 Instructions

  1. Click on the orange V-->Configure-->Displays.
  2. Select the display and click on Edit Display.
  3. Verify Sign configurations are correct and click Next.
  4. Select Serial Communication and click Next.
  5. Select the Com Port that the USB to Serial Adapter has selected and click Next.
  6. Verify the Sign address is correct and click Next.
  7. Verify the Time Zone is correct and click Next.
  8. Click Finish and close out of display management.
  9. Select your display in the Venus 1500 Home tab and verify communication.

KB ID: DD1993300


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