
201 Daktronics Drive
Brookings, SD 57006-5128
www.daktronics.com/support
800.325.8766

DAKSTATS BASEBALL 
SOFTWARE

DISPLAY MANUAL
P1149

DD1533474
Rev 5

28 November 2018



Copyright © 2009-2018
All rights reserved. While every precaution has been taken in the preparation of this manual, the publisher assumes no 
responsibility for errors or omissions. No part of this book covered by the copyrights hereon may be reproduced or copied 
in any form or by any means—graphic, electronic, or mechanical, including photocopying, taping, or information 
storage and retrieval systems—without written permission of the publisher.
Daktronics trademarks are property of Daktronics, Inc. All other trademarks are property of their respective companies.



– i –

Table of Contents
1	 Introduction����������������������������������������������������������������������������������������������������������������������������1

Software Conventions���������������������������������������������������������������������������������������������������������������������������1
2	 DSTI Setup�������������������������������������������������������������������������������������������������������������������������������2

DakStats/DSTI Messaging����������������������������������������������������������������������������������������������������������������������2
Networked Campus��������������������������������������������������������������������������������������������������������������������������2

Selecting DakStats Interface and Database�������������������������������������������������������������������������������������3
Auto Start Options���������������������������������������������������������������������������������������������������������������������������������3
Testing DakStats/DSTI Communication�����������������������������������������������������������������������������������������������3

3	 Viewing & Modifying RTD������������������������������������������������������������������������������������������������������4
At Bat Text����������������������������������������������������������������������������������������������������������������������������������������������4

Editing RTD Batter Text�����������������������������������������������������������������������������������������������������������������������4
Enhanced Batter Text������������������������������������������������������������������������������������������������������������������������5

Manual RTD Output Control�����������������������������������������������������������������������������������������������������������������5
Manual Mode������������������������������������������������������������������������������������������������������������������������������������5

Editing the Pitch Count�������������������������������������������������������������������������������������������������������������������������7
Right-Click Menu�����������������������������������������������������������������������������������������������������������������������������������7
Scoring Text��������������������������������������������������������������������������������������������������������������������������������������������8
Pausing Outputs�������������������������������������������������������������������������������������������������������������������������������������9

4	 RTD Configurations���������������������������������������������������������������������������������������������������������������10
5	 Quick Display�����������������������������������������������������������������������������������������������������������������������11
6	 Player Messages������������������������������������������������������������������������������������������������������������������12

Creating Player Messages������������������������������������������������������������������������������������������������������������������12
Displaying Player Messages���������������������������������������������������������������������������������������������������������������12

A	 Available RTD Items�������������������������������������������������������������������������������������������������������������13



This page intentionally left blank. 



Introduction
1

1	 Introduction
The purpose of this manual is to assist with outputting and displaying Real-Time Data 
(RTD) using the DakStats® Baseball application. The manual includes the following main 
sections: 

•	 Introduction covers the basic information about the program and this manual. 
Take time to read the introduction as it defines terms and explains concepts used 
throughout the manual. 

•	 DSTI Setup, Viewing & Modifying RTD, RTD Configurations, Quick Display, and Player 
Messages explain how to control and configure the application. 

This manual assumes previous knowledge of creating new seasons, teams and rosters, 
as well as creating and opening new games. For general program installation and 
operation instructions, refer to the DakStats Baseball Software Operation Manual 
(DD1385420). 

Software Conventions
This manual contains the following software conventions and terminology: 

Bold
Indicates an item that requires direct action, such as clicking, pressing, 
selecting, or formatting. Also used for reference items within the manual, 
such as figures or sections, as well as other documents and notes. 

Italics Indicates onscreen text or labels that are not clickable. 

[Brackets] Represents a keyboard key that needs to be pressed. 

“Quotes” Text or commands that may be typed. Quotes also indicate folder names. 

Click Press and release the left mouse button. 

Double-click Press and release the left mouse button twice. 

Right-click Press and release the right mouse button. 

Select Highlight or mark, such as by placing a check mark in a nearby box; 
clicking will not necessarily perform an action. 

> Followed by (example: File > Open). 

http://www.daktronics.com/Web Documents/DakStats/DD1385420.pdf
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2	 DSTI Setup
In order for DakStats Baseball to output RTD, the Daktronics Scoring-Timing Interface (DSTI) 
must have been installed. The DSTI software is pre-configured by Daktronics and cannot 
be altered at the installation site. Any desired configuration changes in DSTI must be 
addressed through Daktronics. Refer to the DSTI Software Operation Manual (ED-13009) 
for more information on installing and setting up the DSTI. 

DakStats/DSTI Messaging
The default setting is that the DakStats 
Baseball program is on the same 
computer as the DSTI program (Figure 1). 
Use the following procedure if DakStats 
and DSTI are on separate machines: 

1.	 On the DakStats computer, browse to 
“C:/Program Files/Daktronics”.

2.	 Right-click the Daktronics folder, and 
then select Properties. 

3.	 Click the Sharing tab. 

4.	 Click Share this folder. 

5.	 Click OK. 

6.	 In DSTI, go to Edit > DakStats Messaging, and then select Different Machine. 

7.	 In DakStats, go to Configure > Messaging, and then select Different Machine. 

Networked Campus
In some facilities, multiple DakStats systems may be located on the same network. Data 
communication issues can arise when more than one game is taking place at the same 
time, for instance a baseball game on one field and a softball game on another. In these 
cases, certain default configuration settings must be modified as described below so the 
separate DakStats systems can communicate properly via network messages. 

1.	 Set DakStats and DSTI Messaging for all systems on the network to Different Machine 
as described above. 

2.	 On one DakStats computer navigate to “C:\Daktronics\DakStats Baseball” and 
open the “DakStats Baseball.ini” file in Notepad. 

3.	 Locate the “Main Port” field and change the value to “32224”. 

4.	 On the corresponding DSTI computer, navigate to “C:\Daktronics\Daktronics 
Scoring-Timing Interface” and open the “Daktronics Scoring-Timing Interface.ini” file in 
Notepad.

5.	 Locate the “Main Port” field and change the value to match the setting in the DSTI 
file. 

6.	 Repeat steps 2-5 for any other systems on the network, increasing the “Main Port” 
value by “1” for each additional system (32225, 32226, etc.).

Figure 1: DakStats/DSTI Messaging

https://www.daktronics.com/Web%20Documents/Manuals/ED-13009.pdf
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Selecting DakStats Interface and Database
DSTI must point to the correct sport interface and DakStats database.

1.	 In DSTI, make sure the Sport is set to Baseball/Softball and that the 
Interface is set to DakStats (Figure 2). 

2.	 Go to Edit > Data Configuration. 

3.	 The Database Path must be set to “X:\Daktronics\DakStats 
Baseball” where X represents the appropriate local or network 
drive (Figure 3). 

Auto Start Options
1.	 In DakStats Baseball, click Configure. 

2.	 Check Auto Start Interface to automatically start DSTI when a game is opened. 

3.	 Be sure to also check Auto Start Hit Chart RTD if using other RTD outputs, such as spray 
charts or scorecards. 

Testing DakStats/DSTI Communication
1.	 Open a game in DakStats Baseball. 

2.	 Open DSTI if it did not already open automatically, and click View Data. 

3.	 The DSTI Message Log shows that a Competition opened, and DakStats sends the 
game information, as shown in Figure 4. 

Figure 2: Sport & 
Interface

Figure 3: Data Configuration

Figure 4: DSTI with DakStats Data
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3	 Viewing & Modifying RTD

At Bat Text
The At Bat tab displays the previous 
at bat text and game summary for 
the current batter. This area is used to 
monitor the text that being sent out to 
electronic displays as well as for online 
Webcasts. 

Note: At bat text modification is only available for seasons configured with MLB Rules. 

If there is a problem with the text, or it is 
not appearing correctly: 

•	 Click the pencil icon, modify the text, 
and then click the green checkmark 
to save the changes (Figure 5). 

To modify batters’ text before they are 
at bat: 

•	 Right-click a player’s name in the 
roster and click Edit Batter Text to 
open the Edit Batter Text window 
(Figure 6). Make the appropriate 
changes and click OK. 

Note: Once the at bat text has been modified, it will no longer receive updates. 
Click the undo  button to return to the default values and resume automatic 
updates to this field. 

Editing RTD Batter Text
The Edit RTD Batter Text window (Figure 7) sets how certain types of text will appear for 
batters’ previous at bats. 

1.	 Go to Configure > 
Batter Text. 

2.	 Click a text box once to 
select it, and then click 
it again to begin typing 
in the new at bat text. 

3.	 Click Restore All 
Defaults to return the 
original settings, or click 
OK to save the new 
text. 

Figure 5: Editing At Bat Text

Figure 6: Edit Batter Text

Figure 7: Edit RTD Batter Text
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Note: It is possible set alerts when the text is close 
to reaching the length that the RTD field 
occupies on the display layout to make sure 
data does not get cut off. The text box turns 
yellow when the limit is approaching and turns 
red when the limit is exceeded. 

Enhanced Batter Text
Use enhanced batter text to 
include additional play or player 
information along with previous at 
bat text. 

1.	 Go to Configure > 
Configurations. 

2.	 Click Configure to open 
the Enhanced Batter Text 
Configuration window 
(Figure 8). 

3.	 Check the box next to Errors, 
Home Runs, RBI, Sequence, 
Run, and/or Stolen Bases to 
display this extra information in 
the batter text. 

4.	 Insert other stats and 
information as desired 
according to the Legend. 

5.	 Click Restore Default to bring 
back the original settings, or 
click OK to save the enhanced 
text. 

Manual RTD Output Control

Manual Mode
Use the Manual tab (Figure 9) 
to manually enter game stats to 
send scoring data to scoreboards 
and displays live during a game. 
This keeps the current scoreboard 
output correct while allowing the 
operator to get caught up from 
editing or deleting plays in the 
commentary. 

Figure 8: Configure Enhanced Batter Text

Figure 9: Manual
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Stats may be entered by clicking the following buttons or Hotkeys: 

•	 B (+): Add a ball

•	 Sh-B (–): Subtract a ball

•	 S (+): Add a strike

•	 Sh-S (–): Subtract a strike

•	 F (+): Add a foul

•	 Sh-F (–): Subtract a foul

•	 Clear Balls/Strikes  
(press [C])

•	 O (+): Add an out

•	 Sh-O (–): Subtract an out

•	 R (+): Add a run

•	 Sh-R (–): Subtract a run

•	 I (+): Add an inning

•	 Sh-I (–): Subtract an inning

•	 A (+): Add an at bat

•	 Sh-A (–): Subtract an at bat

Visitor

•	 H (+): Add a hit 

•	 Sh-H (–): Subtract a hit 

•	 E (+): Add an error 

•	 Sh-E (–): Subtract an error 

•	 L (+): Add an LOB 

•	 Sh-L (–): Subtract an LOB 

Home

•	 Ctrl-H (+): Add a hit 

•	 Ctrl-Sh-H (–): Subtract a hit

•	 Ctrl-E (+): Add an error

•	 Ctrl-Sh-E (–): Subtract an 
error

•	 Ctrl-L (+): Add an LOB

•	 Ctrl-Sh-L (–): Subtract an LOB

Note:	 Sh means to hold the 
[Shift] key while pressing 
the letter key.

Once any stats have been manually changed, the linescore will become yellow to 
indicate the program is operating in Manual Mode (Figure 10).

Figure 10: Manual Mode

To exit Manual Mode: 

1.	 Click Exit Manual Mode. A window will appear showing a comparison between the 
changes that were made in manual mode and the plays as entered in the play-by-
play commentary (Figure 11). 

2.	 Click Yes to confirm that the stats are up-to-date and leave manual mode. 

Figure 11: Exit Manual Mode
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Editing the Pitch Count
If the pitch count (number of 
pitches thrown by current pitchers) 
is incorrect on the scoreboard or 
display: 

1.	 Go to Edit > Edit Pitch Count. 

2.	 In the Edit Total Pitches Thrown 
window (Figure 12), update the 
number of balls or strikes for the 
appropriate pitchers. 

3.	 Click Select Previous Pitcher if a 
previous pitcher’s count needs 
to be adjusted. 

4.	 Click OK when finished, or click 
Cancel to discard the changes. 

Right-Click Menu
Players in the roster list can be right-
clicked to access additional editing tools 
(Figure 13). 

Note: Right-clicking is only available for 
seasons configured with MLB Rules. 

•	 Edit Batter Text: Refer to At Bat Text 
(p.4). 

•	 Edit Season Stats: Click to quickly 
modify a player’s season stats without 
leaving play-by-play mode (Figure 14). 

Figure 14: Edit Season Stats

•	 Click the Batting, Pitching, or Pitching Game tab. 

•	 Either double-click a stat to increase it by one, double-right-click to decrease by 
one, or select a stat and type in the new value. 

•	 Use the [<<] and [>>] buttons to switch between players or select another player 
from the team’s roster list. 

Figure 12: Edit Total Pitches Thrown

Figure 13: Right-Click Menu
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•	 Add to Bullpen #1 & Add to Bullpen #2: Use these options to denote which pitchers 
are in the bullpen. Pitchers currently in the bullpen will have B1 or B2 next to their 
jersey number. If the pitchers are marked as Remaining, they show a 1/P or 2/P 
instead. 

•	 Clear Bullpen: Click to remove all pitchers from the team’s bullpen. To remove a 
specific player from a bullpen, right-click the player and select the appropriate 
Remove from Bullpen option. 

•	 Add to Remaining Pitchers: Use this option to denote which pitchers are left. Pitchers 
marked as remaining will have a P next to their jersey number. If the pitchers are 
marked as in a bullpen, they show a 1/P or 2/P instead. In the output, remaining 
pitchers are grouped by Right-Handed and Left-Handed, with up to 8 of each on 
both teams (32 max pitchers). 

•	 Clear Remaining Pitchers: Click to clear all pitchers marked as Remaining. 

Note: Outputting bullpen RTD requires another port in addition to the scoreboard 
and requested stream outputs in the Daktronics Scoring-Timing Interface (DSTI) 
application. Contact Daktronics to request an updated DSI file that includes a 
Bullpen output port. 

Scoring Text
Similar to at bat text, the Edit 
Scoring Text window (Figure 15) 
allows customization of the 
appearance of scoring decision 
text. This is also used for the text 
that appears in the graphics 
created in the Scorebook 
Generator program. 

1.	 Go to Configure > Scoring Text. 

2.	 Click a text box once to select 
it, and then click it again to 
begin typing in the new scoring 
text. 

3.	 Select Display Out Sequence 
Dash and/or Display Full Out 
Sequence if desired. 

4.	 Click Restore Defaults to return 
the original settings, or click OK 
to save the new text. 

To break the Text into multiple lines, 
type in “<BR>”. The <BR> tag will 
not appear in the RTD stream, but 
instead will split any remaining text 
onto another line to better fit on scorecard graphics. 

Click Send Text to resend the updated play abbreviations, for example if the Scorebook 
Generator program was running at the time they were modified. 

Figure 15: Edit Scoring Text
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Pausing Outputs
Sometimes it may be necessary to change data in DakStats 
without it being immediately displayed. In these cases, go to 
View > Pause/Resume Outputs Toolbar and click the Pause 
Outputs button (Figure 16). This will keep all data currently being 
displayed as is while changes can be made. The green circle will 
turn red to indicate no data is outputting. When finished making 
changes, click the Resume Outputs button, and the red circle 
will turn green again to indicate the updated data is being sent. 

Figure 16: Pause/Resume 
Outputs
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4	 RTD Configurations
The Configurations window 
includes several settings related to 
outputting RTD. Go to Configure 
> Configurations to access the 
Configurations window (Figure 17). 

•	 Under Display of Batter’s 
Previous at Bats, select to 
display the batter’s previous 
at bats by Ascending or 
Descending. 

•	 Select whether to use 
Enhanced Batter Text. Refer to 
Enhanced Batter Text (p.5).

•	 Check whether or not to Use 
Hit/Error Info Control for RTD. 
This will enable an edit control 
in the toolbar to instantly 
update the RTD stream about 
the play: 

Select whether there was a hit 
or error (or none), type in the 
desired text, and press [Enter] 
to update. The number of 
characters is limited to 25. 

•	 Enable Use Automatic Scoring Decision to automatically send the scoring text as 
soon as the play is entered. This can be used in conjunction with the Hit/Error Control 
described above to fill in the play for the user to edit.

•	 Under RTD Linescore Settings, select to have the linescore Grouped (place inning 
10 in the first inning position) or Shifted (remove the earliest innings to make room for 
additional innings), and how many innings to show in the RTD Linescore. 

Figure 17: Configurations
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5	 Quick Display
The Quick Display option allows users who interface with Daktronics display controllers 
to run sequences from DakStats Baseball. These settings do not need to be modified 
if the DakStats Baseball program is not interfacing with a display controller. For more 
information about creating sequences, refer to the documentation provided with the 
display control software. 

1.	 Make sure to have DakStats Baseball, DSTI, and the display controller running. 

2.	 In DakStats Baseball, go to 
Configure > Quick Display, 
and the Quick Display window 
will appear (Figure 18). 

3.	 If the Empty Interface 
Configuration File! message 
appears at the bottom of the 
window, click Request Config. 

4.	 Right-click an empty cell, and 
then click Add Item; to modify 
an existing cell, right-click the 
cell, and click Edit Item: 

a.	 In the Configure Quick 
Display Item window 
(Figure 19), check the box 
next to Show on toolbar. 

b.	 Type in a descriptive Item Name. 

c.	 Fill in the Enhanced RTD 
Parameters to specify the 
desired sequence to play. 

d.	 Fill in the Request Parameters 
to specify what type of data to 
output. 

Note: Items with the %Select 
Nickname are not 
compatible with quick 
display buttons. 

e.	 Click OK to save the changes to 
the quick display button. 

5.	 Repeat Step 4 to assign up to 20 
other commands on the toolbar. 

6.	 To delete an existing cell, right-click 
the cell, and click Delete Item. 

7.	 Click Close when finished creating the quick display buttons. 

8.	 Go to View > Quick Display Toolbar to make the Quick Display Toolbar appear 
above the standard toolbar. 

9.	 The QD Toolbar can be undocked and moved, and it also will dock on either side or 
the bottom of the screen. 

Figure 18: Quick Display

Figure 19: Configure Quick Display Item
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6	 Player Messages
Use player messages to add any number of informative notes about individual players 
that can be sent as RTD to displays. 

Creating Player Messages
1.	 Go to Configure > 

Player Messages. 

2.	 In the Player Messages 
window (Figure 20), 
select a Season and a 
Team. 

3.	 Select a Player, and 
then click Add New to 
create a new message 
for the player. 

4.	 Type in a short 
Description of the 
message. 

5.	 Type in the message 
one line at a time, using 
up to 26 characters per 
line. 

6.	 Check Wrap Text if desired to automatically push longer words to the next line. 

7.	 Choose Left, Center, or Right alignment for the text. 

8.	 Click Delete to remove the message, or click Save to keep the message. 

9.	 Repeat Steps 2–8 to create as many messages as needed for each player. 

Displaying Player Messages
To display messages for a specific player, set up a Quick Display button. 

1.	 Follow Steps 1–4c in Section 5: Quick Display (p.11). 

2.	 In the Configure Quick Display Item window (Figure 19), enter the following settings 
under the Request Parameters area: 

•	 DSTI Port Name: Venus Request – Network 

•	 Format: PlrMessages

•	 Nickname: Select either Home or Guest, or a specific team name. 

•	 Number: Select the player’s jersey number. 

•	 (Lastname): Select the player’s last name. 

•	 Message#: Type in the message number to be displayed. 

3.	 Click OK when finished. 

At this point, a message request button for each player may be created. 

Figure 20: Player Messages
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A	 Available RTD Items
Refer to the DakStats Baseball Interface Product Specifications (SL-06041) for the latest list 
of available RTD fields. 

All ITF/DID files below are located at http://dakfiles.daktronics.com/downloads/Data/

Scoreboard Stream Files: 

•	 “DSTI DSBA Scoreboard” (Pre-2007: “dsba sbrd”)

Requested Stream Files: 

•	 Game and Season Stats: “dsba req”

•	 Game Summary: “DSTI DSBA Game Summary req”

•	 Player Message: “DSTI DSBA Plr Msg req”

•	 Player Positions: “DSTI DSBA Position Lineups”

•	 Pitchers in Bullpen: “DSTI DSBA Bullpen”

https://www.daktronics.com/Web%20Documents/HSPR-Documents/SL06041.pdf
http://dakfiles.daktronics.com/downloads/Data/
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