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Section 1: Introduction 

The purpose of this manual is to assist users with the installation and operation of the Daktronics 
Scorebook Generator application.  
 
The manual is divided into four main sections: 
 

 Introduction covers the basic information about the program and this manual. Take time to 
read the introduction as it defines terms and explains concepts used throughout the manual. 

 Installation describes the installation procedures of the Scorebook Generator application. 

 Operation details the specific operation of the Scorebook Generator application. 

 Contact Information offers details about who to contact for help. 
 

Daktronics identifies manuals by an ED or DD number located on the cover page of each manual. 
Any manuals referenced in this document will be identified by its ED/DD number. For example, this 
manual would be referred to as DD1361705. 

1.1 Software Overview 

The Scorebook Generator application creates digital scorecards, similar to those that are 
traditionally written out by hand. Data of current and previous plays is received from 
DakStats® Baseball, and then it is rendered in graphical representations that can be sent to 
displays using Daktronics display controllers.  

1.2 Major Features 

The major features of the Scorebook Generator application are: 

 Displays at a glance what’s has happened with the ball and batter each time they 
have been at bat during the game.  
 

 Offers users the choice of showing the previous at bats for the current batter, 
previous at bats for due ups, for the action so far in the inning, or all of the above for 
home and visiting teams.  
 

 Allows up to five different configurations for displaying at bat data.  
 

 In-depth customization of colors and fonts.  

1.3 System Requirements 

The Scorebook Generator application has the following system requirements: 

 Microsoft Windows XP or better  

 IBM or 100% compatible PC, Pentium 1.5 GHz or higher 

 1GB RAM 

 20MB free disk space 

 Mouse or other pointing device 

 Keyboard 
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1.4 Software Conventions 

This manual contains the following software conventions and terminology: 

 

Bold Indicates an item that requires direct action, such as clicking, pressing, 
selecting or formatting. 

Italics Indicates onscreen text or labels that are not clickable. 

Bold Italics Used to reference items within the manual, such as figures or sections, as 
well as other documents and important notes.  

[X] Represents a keyboard key that needs to be pressed. 

“Quotes” Text or commands that may be typed. Quotes also indicate folder names. 

Click Press and release the left mouse button. 

Double-click Press and release the left mouse button twice. 

Right-click Press and release the right mouse button. 

Select Highlight or mark, such as by placing a check mark  in a nearby box; 
clicking will not necessarily perform an action. 

> Followed by (ex. File > Open). 

1.5 Definitions 

The following terms and definitions are used throughout this manual and the software: 

 Configuration: All settings used to create a graphical representation of at bat data. 

 DSTI: Daktronics Scoring-Timing Interface. The application that provides scoreboard 
and requested data feeds to the Daktronics display controllers.  

 ITF: Input Template File. A file for Daktronics software that specifies the format of 
the data being received by a Daktronics data source.  

 ERTD: Enhanced Real Time Data. A Daktronics protocol used to share data between 
applications and to send commands to display controllers. 

 User/Operator(s): The person(s) running and configuring the application.  

 Venus 7000: Daktronics control software used to send data/commands to a display.  
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Section 2: Installation 

2.1 Installing the Software 

To install the Scorebook Generator application: 
1. Open an Internet browser to http://dakfiles.daktronics.com/downloads/DakStats. 
2. Click the “ScorebookGeneratorInstall.exe” file, and then click Run to begin the 

installation procedure. 
 
Note: Click Run again if a security warning appears. 
 

3. In the Setup Wizard window, click Next (Figure 1).  

4. Choose the appropriate installation options if necessary, and then click Next, 
5. In the following window, click Next once more.  
6. In the Daktronics Licensing window (Figure 2), click OK if the initialization was 

successful, or click Try Again if the initialization failed.  

 
7. Wait for all the files to be extracted, and then click Close (Figure 3). 

 
Figure 1: Setup Wizard Window 

 
Figure 2: Daktronics Licensing 

http://dakfiles.daktronics.com/downloads/DakStats
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2.2 Running the Software 

To open the Scorebook Generator application:  

 Double-click the “Scorebook Generator” icon on the desktop. 
Or  

 Go to Start > All Programs > Daktronics > Scorebook Generator. 

2.3 Registering the Software 

When the Scorebook Generator application is first opened, users are required to attain a new 
software license (Figure 4) in order for the program to work.  
 
To renew the subscription: 

1. Highlight and Copy the Lock Code. 
2. Email the Lock Code to dakstats@daktronics.com with the subject line “Scorebook 

Generator Lock Code” and a license file will be emailed back. 
3. When the license file is received, save it to a location that is easy to remember, such 

as “My Documents” or the “Desktop”.  
4. Click Load License, and then locate and open the license file.  
5. Click Continue to begin using the Scorebook Generator application. 

 

 
Figure 3: Installation Complete 

 
Figure 4: Registration Screen 

mailto:dakstats@daktronics.com
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Section 3: Operation 

The Scorebook Generator application gathers game data from DakStats Baseball, and it runs on the 
same computer as the Daktronics display controller. By creating configurations, image files of at bat 
data are saved to the computer to be accessed by the display controller and sent to a display. After the 
initial setup, an operator is needed only to launch the application and occasionally modify the 
configurations or resolve errors.  
 
Refer to the DakStats Baseball Software Operation Manual (DD1385420) and the DakStats Baseball 
Software Display Manual (DD1533474) for more information on how to use this program.  
 
This section of the manual on program operation covers four main topics:  

 DakStats Baseball Setup 

 Main Application Screen 

 Scorebook Configurations 

 Managing Configurations 

3.1 DakStats Baseball Setup 

Before and during use of the Scorebook Generator application, there are additional 
configuration and processes that must be performed in DakStats Baseball.  

Enabling Hit Chart RTD 

1. Open DakStats Baseball. 
2. Click Configure. 
3. Click Auto Start Hit Chart RTD, (Figure 5) and it will be marked with a check. 

 
Figure 5: Auto Start Hit Chart RTD 
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Entering Hit To Locations & Sequences 

When entering a Hit To location in DakStats Baseball, it will be necessary to click on the 
location in the picture rather than typing them in the text box (Figure 6). It is also necessary to 
click on the names/numbers of the players when entering the Sequence of an out (Figure 7). 
This is how the Scorebook Generator application generates the correct coordinates to display.  
 

3.2 Main Application Screen 

The Scorebook Generator main application screen (Figure 8) contains three menu buttons, a 
status area, a list of available configurations, and five control buttons. 
 

 

 
Figure 6: Clicking a Hit To Location 

 
Figure 7: Clicking Player Locations 

 

Figure 8: Main Application Screen with no Configurations 
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File Menu 

The File menu (Figure 9) contains the following buttons: 
 

 Exit:  Click to close the program.  

 Redraw Images: Click to manually redraw and save every image. 

Configure Menu 

Use the Configure menu (Figure 10) contains the following buttons: 
 

 Add Configuration: Click to add a new configuration to the list after an empty 
number has been selected (Section 3.2). 

 Edit Configuration: Click to modify a chosen configuration (Section 3.3). 

 Delete Configuration: Click to delete a chosen configuration (Section 3.3). 

 Play Text: Click to request/view play text from DakStats Baseball (Section 3.5). 

Help Menu  

The Help menu (Figure 11) contains the following buttons: 
 

 About Scorebook Generator: Click to view version and contact information 
about the Scorebook Generator application.  

 View Manual: Click to open a PDF file of the operation manual.  

 Registration: Click to load new registration license files.  
 
 
 
 
 
 
 

 
Figure 9: File Menu 

 
Figure 10: Configure Menu 

 
Figure 11: Help Menu 
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Status 

The Status area (Figure 12) displays messages about port availability and data reception from 
DakStats Baseball. This area can be used to help diagnose connection problems. 

Configuration List 

The Configuration List area (Figure 13) will show the following information about 
configurations as they are created and enabled:  

 

  #: The configuration number 

 Name: The user-defined configuration name  

 Last Update: The last time an image was rendered for that configuration 

 Notes: Messages related to configuration editing and image rendering  

Control Buttons 

The control buttons on the bottom of the main application screen can also be found in the 
Configure menu: 
 

 Add Configuration: Click to add a new configuration to the list after an empty 
number has been selected (Section 3.2). 

 Edit Configuration: Click to modify a chosen configuration (Section 3.3). 

 Delete Configuration: Click to delete a chosen configuration (Section 3.3). 
 

 

 

 

 

 

 

 

 
Figure 12: Status Area 

 
Figure 13: Configuration List 
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3.3 Scorebook Configurations 

The Scorebook Generator application features a wide variety of options for displaying at bat 
information. This section explains the process of creating a new configuration that sets up 
these options. Each option on the Configuration screen (Figure 16) is defined, as well as how it 
may be customized.  

Creating New Configurations 

To create a new configuration: 
 

1. On the main application screen, click an empty number 1-5 to highlight the line in 
blue (Figure 14).  

2. Click Add Configuration or navigate to Configure > Add Configuration and the 
Configuration screen will appear (Figure 15). 
 
Note: Most of the options will be unavailable at this point. 

 
Figure 14: Adding a New Configuration 

 
Figure 15: Empty Configuration Screen 
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3. Type in a descriptive Name for the configuration. 
4. In the Output Location (Home) and Output Location (Visitor) text boxes, type in or click 

the  button to navigate to the file path to the folder where the image files will be 
saved if different from the “D:\V7000\Bitmaps” default path.  

5. Choose one of following three tabs depending on the type of information this 
particular configuration will display: 

 Current Batter: Displays information about any number of the current batter’s 
previous at bats. 

 Due Ups: Displays the previous at bats for the three upcoming batters. 

 Previous At Bat: Displays the at bats for previous batters in the inning.  
 

Note: The options contained within each tab are identical unless indicated otherwise. 
 
6. Click Enable, and the options will become selectable, as shown in Figure 16.  
7. Adjust each option to the desired settings (see Configuration Options). 
8. Repeat steps 6–7 for additional tabs if desired.  
9. Click OK to save the configuration, or click Cancel to discard the changes. 

Configuration Options 

When creating or modifying an enabled configuration, the following options are available: 

 Safe Hit To Location: Enable this option to show an arc to where a safe ball was hit. 
Select a Thickness of the arc, and click the colored box to select the font Color. 
 

 Safe Elements: Enable this option to display text stating what base the batter reached 

after hitting a safe ball. Click the  button to format the Font, and click the colored 
box to select the element Color. Enable Drop Shadow to put a shadow on the element 
text, and click the colored box to select the Color (enter a Drop Shadow Distance from 
“1”-“10” if desired). Enable Show HR Distance to display the distance of a home run 
(this value must be set in DakStats). 
 

 
Figure 16: Enabled Configuration Screen 
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 Out Hit To Location: Enable this option to show an arc where a ball was hit that 
resulted in an out. Select a Thickness of the arc, and click the colored box to select the 
font Color. 

 

 Out Elements: Enable this option to display text stating the type and sequence of an 

out. Click the  button to format the Font, and click the colored box to select the 
element Color. Enable Drop Shadow to put a shadow on the element text, and click the 
colored box to select the Color (enter a Drop Shadow Distance from “1”-“10” if desired). 
 

 Size of Each At Bat: Enter in the Width or the Height in pixels for each at bat image.  
 
Note: Be sure to multiply the Width value to find the total length of a series of at bat 
images when setting up display sequences.  
 

 Non-Batted Innings: Enable this option to display an image even if the batter did not 
bat that inning. Choose Normal to show an empty ballpark image, or choose Darken 
to grey out the image.  
 
Note: This option will always be unavailable on the Previous At Bat tab. 
 

 Out Sequence: Enable to show the sequence of throws leading to an out. Enable 
Display Dash to place a dash between players in the sequence of outs. Enable Full 
Sequence to avoid automatically shortening long out sequences.  
 
Note: If Full Sequence is disabled, only the first, second, and last throws of the out 
sequence will be displayed.  
 

 RBI Dots: Enable this option to display a small dot to indicate that the batter was 
eventually batted in. Click the colored box to select the dot Color. 
 

 Baserunning Path: Enable this option to put a thick line indicating what base the batter 
made it to. Click the colored box to select the path Color. Enable Fill in on Run to 
darken the infield when a batter makes it back to home plate. Click the colored box to 
select the Fill Color. Enable Show out dash to place a slash across the path where the 
runner was tagged out. 
 

 Inning Text: Enable this option to show the inning number with each image. Click the 

 button to format the Font, and click the colored box to select the font Color. Enable 
Drop Shadow to put a shadow on the element text, and click the colored box to select 
the Color (enter a Drop Shadow Distance from “1”-“10” if desired). Enable Append 
Ordinal to display innings as 1st, 2nd, 3rd, etc., instead of 1, 2, 3, etc. 
 

 # of Shown At Bats: Select or type in the number of total at bats to display at once.  
As this number decreases, the most recent at bats are displayed. Enable Draw Current 
Inning Only to show a single at bat for both the current and previous half inning. For 
example, at the top of the 5th, the last at bat for the Visitor will be displayed along 
with the last at bat for the Home team in the bottom of the 4th; at the bottom of the 5th, 
the last at bat for the Home team will be displayed along with the last at bat for the 
Visitor in the top of the 5th. 
 
Note: This option will always be unavailable on the Previous At Bat tab.  
Draw Current Inning Only is available on Current Batter tab only. 
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 Template Type: Choose a template to determine the look and dimensions of the 
baseball diamond background image. Contact Daktronics to create custom templates. 
 

 Image Format: Choose from Bitmap, JPEG, GIF, or PNG image formats. Bitmap is the 
largest file size, PNG second largest, GIF is typically the smallest, and JPEG is 
variable. PNG images allow for transparency effects on supported display outputs. 
 

 Quality: Use the slider bar to adjust the file size of JPEG images only.  
 

 Sample: This area displays an active preview of all the current settings applied to 
some sample at bat data. Click the image(s) to view the at bat(s) in a separate 
window (Figure 17).  

Note: If the preview image(s) cannot be rendered due to invalid image dimensions,  

a symbol will appear in the Sample area that looks like this: . Be sure to change the 
appropriate settings and make this error symbol go away before saving the configuration. 

3.4 Managing Configurations 

After configurations have been created, the Scorebook Generator main application screen 
provides several ways to manage them (Figure 18). This section explains how to edit, 
enable/disable, and delete configurations.  

Editing Configurations 

To edit a configuration: 
1. On the main application screen, click the configuration to be modified, and it will be 

highlighted in blue.  
2. Click Edit Configuration or navigate to Configure > Edit Configuration to return to 

the Configuration screen (Figure 16).  
3. Go to the tab(s) that require changes and adjust the configuration options 

accordingly.  

 
Figure 17: Sample At Bat Images 

 
Figure 18: Main Application Screen with Configurations 
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4. Click OK to save the configuration, or click Cancel to discard the changes. 

Enabling & Disabling Configurations 

As new configurations are added, they are enabled by default.  
 
To disable a configuration: 

 On the main application screen, 
click the checkbox next to or 
double-click the information of 
the configuration to be 
disabled. The green light will 
turn red to indicate the 
configuration is no longer 
creating and sending images to the Output Location folder(s) (Figure 19). 
 

To re-enable a configuration: 

 On the main application screen, click the checkbox next to or double-click the 
information of the disabled configuration to turn it back on.  
 
Note: New images are rendered and saved every 30 seconds, and the green light will 
become brighter during this process (Figure 20).  

Deleting Configurations 

To delete a configuration: 
1. On the main application screen, click the configuration to be deleted, and it will be 

highlighted in blue.  
2. Click Delete Configuration or navigate to Configure > Delete Configuration. 
3. Click Yes to permanently remove the configuration.  
4. Rearrange any remaining configurations as needed.  

3.5 Editing & Viewing Play Text 

Changing the wording of the play text is 
accomplished in DakStats Baseball. 
 

1. With DakStats Baseball open, go to 
Configure > Scoring Text. 

2. In the Edit Scoring Text window (Figure 
21), there is a Play description along with 
some abbreviated Text that is displayed 
for that play type. Double-click a field 
under the Text column to edit. 

3. Click OK to save the changes, Cancel to 
discard the changes, or Restore Defaults 
to bring back the original text settings. 

 
To break the Text into multiple lines, type in 
“<BR>”. The <BR> tag will not appear in the RTD 

 
Figure 19: Enabled & Disabled Configurations 

 
Figure 20: Active Configuration 

 
Figure 21: Edit Scoring Text Window 
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stream, but instead will split any remaining text onto another line to better fit on scorecard 
graphics. 
 
Play text can be viewed in Scorebook Generator by 
going to Configure > Play Text.  
 
If DakStats Baseball is open and nothing appears in 
the Play Text window (Figure 22), click Request 
Strings to retrieve the most recent play text fields. 
 

Note: It is not possible to edit the play text 
from within Scorebook Generator. 

 
 
 
 
 
 
 
 

3.6 Creating Display Sequences with Scorecard Graphics 

Once the proper configurations have been set up and the program is outputting the desired 
scorecard graphics, users can begin integrating these images into their display sequences.  
The Daktronics Sport Software Baseball Display Cookbook (DD1584319) offers several tips 
and tricks for laying out display sequences featuring both text and image RTD.  
 
Each scorecard graphic can be placed into a display sequence as a standalone piece of image 
RTD or as a complement to at bat text (Figure 23).  
 

 
Note: Outputting the scorecard graphics to the display controller requires an additional port 
in the Daktronics Scoring-Timing Interface (DSTI) application. Contact Daktronics to receive 
an updated DSI file that includes a Scorebook Generator output port. 
 

 
Figure 22: Play Text Window 

 
Figure 23: Sample Sequence with Scorecards 
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Section 4: Contact Information 

If there are any questions about installing, registering, or setting up any of the programs mentioned in 

this manual, please contact DakStats Customer Service: 
 
Mail: Daktronics, Inc., Customer Service 

201 Daktronics Drive 
P.O. Box 5128 
Brookings, SD   57006 
 

Phone: DakStats Help Desk: 1-888-325-7828  
 
DakStats Fax: 1-605-697-4700 Attn: DakStats 
 
Email: dakstats@daktronics.com 
 

 

mailto:dakstats@daktronics.com
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